Back
Resolved

Europe server migration finished

Started 1 Jun at 12:24am CEST.

Sync: EU CENTRAL
Created

We recently finished migration to the new Europe synchronization server. This should bring better stability and reliability for EMEA users.

Posted 1 Jun at 12:24am CEST.